Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen beim Xpage Anwender-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Klaus3714

Einsteiger

Beiträge: 14

Xpage-Version: Xpage Internet Studio 7 Professional

Betriebssystem: Windows 7

1

Sonntag, 12. Juli 2009, 15:00

Passwortgeschützte Seiten


Hallo zusammen!

Ich habe ein Projekt erstellt mit einen passwortgeschützem Ordner und einer integrierten Seite "Intern". Ich bin genau so vorgegangen

wie im Handbuch beschrieben: Benutzername und Passwort eingegeben, bei Projekteigenschaften Url eingegeben und

alles mit Auto-Upload (um nichts zu vergessen) hochgeladen. Die Seite "Intern" ist von der Navigationsleiste aus verlinkt.

Bei Ansehen der Homepage wird keine Passwortabfrage oder ähnliches angezeigt, sondern direkt zur Seite "Intern" gesprungen. Was mache ich falsch?

Für eine Antwort bin ich sehr dankbar!

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Klaus3714« (12. Juli 2009, 15:07)

  • Zum Seitenanfang

Bodo Wünsch

Fortgeschrittener

Beiträge: 40

Xpage-Version: Xpage Internet Studio 6 Professional

Wohnort: München

Betriebssystem: Windows XP
MAC OS X

2

Sonntag, 12. Juli 2009, 16:52

Hallo,
spontan würde mir einfallen, noch einmal den Passworteintrag im Kontextmenü zum passwortgeschützen Ordner, in der ihre */intern.html liegt, einzugeben und, wichtig: mit Enter /Return zu bestätigen.

Gggfs. alle Script-Dateien auf dem Server vor einem neuerlichen Upload mal löschen.

Viele Grüße
Bodo Wünsch
  • Zum Seitenanfang

Klaus3714

Einsteiger

Beiträge: 14

Xpage-Version: Xpage Internet Studio 7 Professional

Betriebssystem: Windows 7

3

Sonntag, 12. Juli 2009, 17:38

Passwortgeschützte Seiten

Hallo Bodo Wünsch,

danke für die Ratschläge, habe sie alle befolgt, hat aber leider nichts genützt.

Viele Grüße Klaus3714
  • Zum Seitenanfang

Kai Rost

Experten-Team

Beiträge: 195

Xpage-Version: Xpage Internet Studio 6 Professional

Wohnort: Nähe von Bremen

Betriebssystem: Windows 7

4

Sonntag, 12. Juli 2009, 19:22

Hallo Klaus3714,

haben Sie einmal Ihr Web-Paket überprüft, ob Passwort geschützte Seiten dort überhaupt unterstützt werden? Leider ist das oftmals bei Einsteigerpaketen nicht inbegriffen. Im Zweifel bei Ihrem Provider nachfragen.

Gruß Kai Rost
  • Zum Seitenanfang

Klaus3714

Einsteiger

Beiträge: 14

Xpage-Version: Xpage Internet Studio 7 Professional

Betriebssystem: Windows 7

5

Sonntag, 12. Juli 2009, 20:00

Hallo Kai Rost,

bei dem Provider handelt es sich um einen großen führenden Anbieter

und das Paket ist auch kein Einsteigerpaket.

Danke für Ihre Mühe

Viele Grüße Klaus3714
  • Zum Seitenanfang

Wassermann

Experten-Team

Beiträge: 336

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 7 SE

Wohnort: Schweiz

Betriebssystem: MAC OS X

6

Montag, 13. Juli 2009, 05:42

Hallo Klaus 1347



Auch bei Grossen Anbieter giebt es Abo unterschieden. bei dem ist php tauglich der ander nicht und so weiter.

Hast Du wie Bodo Wünsch mal wie beschrieben hat wirklich alles gelöscht und neu Hochgeladen ?

Habe mal eine dumme Frage; liegen die zu Schützenden Seiten im Geschütztdem Ordner ? ist die Verlinkung alles Ok?

Sind alles Faktoren die im Altem Forum noch zu lesen sind. vieleicht liest du auch da mal Durch ;-)



Gruss Wassermann.
  • Zum Seitenanfang

Klaus3714

Einsteiger

Beiträge: 14

Xpage-Version: Xpage Internet Studio 7 Professional

Betriebssystem: Windows 7

7

Mittwoch, 15. Juli 2009, 09:02

Passwortgeschützte Seiten

Hallo zusammen!

Den Passwortschutz mit Xpage habe ich leider nicht hinbekommen, er wurde mir jetzt vom Provider zur Verfügung gestellt.

Was mich interessieren würde: Wird der Xpage-Passwortschutz nur einmal pro Sitzung generiert (wie beim Provider) oder bei jedem Klick auf den betreffenden Link ?

Vielen Dank und Grüße Klaus3714
  • Zum Seitenanfang

Kai Rost

Experten-Team

Beiträge: 195

Xpage-Version: Xpage Internet Studio 6 Professional

Wohnort: Nähe von Bremen

Betriebssystem: Windows 7

8

Mittwoch, 15. Juli 2009, 13:23

Schon mal probiert, ob der Xpage-Passwortschutz jetzt funktioniert? Das ist genau das, was ich Ihnen geschrieben hatte: Der Provider schützt die Seiten mit der Standard-Funktion .htcaccess. Die muss nämlich freigeschaltet sein, damit Xpage diese Funktion nutzen kann. Das ist nicht in jedem Webpaket inbegriffen.

Nach Eingabe von Benutzer und Passwort bleiben die Seiten solange offen, bis die Session beendet ist.

Gruß Kai Rost
  • Zum Seitenanfang

my-poi

Einsteiger

Beiträge: 5

Xpage-Version: Xpage Internet Studio 6 Professional
Xpage Internet Studio Shop-Designer

Wohnort: bei Rostock

Betriebssystem: Windows XP

9

Sonntag, 25. Oktober 2009, 17:08

Das gleiche Problem

Ich habe auch lange rumexperimentiert. Es ist nicht hinzukriegen die entsprechende Seite mit Passwörtern zu schützen, die Passwortabfrage wird einfach ignoriert. Ich habe mir so beholfen, das ich einen separaten Passwortschutz erzeuge und diesen dann per ftp in den jeweiligen Ordner ablege. Ist zwar etwas auf Umwege, aber es geht. Also kann es nicht am Provider liegen, denn sonst würde es auf diesem Weg auch nicht funktionieren. Wer es testen möchte hier www.my-poi.de (>> auf Anmeldung) Würde mich auch über einen Hinweis freuen, wie es mit Xpage geht.

Gruß Bodo
  • Zum Seitenanfang

Schlitzauge

Fortgeschrittener

Beiträge: 38

Xpage-Version: Xpage Internet Studio 6 Professional
Xpage Internet Studio 6 SE
Xpage Internet Studio Shop-Designer

Betriebssystem: Windows XP
Windows 2000
Windows Vista
Linux

10

Sonntag, 6. Juni 2010, 02:36

Zitat

Der Provider schützt die Seiten mit der Standard-Funktion .htcaccess. Die muss nämlich freigeschaltet sein, damit Xpage diese Funktion nutzen kann. Das ist nicht in jedem Webpaket inbegriffen.
Das ist in der Tat richtig, aber von einer Funktion zu sprechen, denke ich, ist falsch.
Es ist halt eine Konfigurations-Sache des auf dem Server verwendeten Webservers.

An sich sind für den Passwortschutz von Verzeichnissen zwei Dateien zuständig:

.htaccess
und
.htpasswd

,zumindest unter Linux-Systemen so.
Diese kann man erstellen, ja sogar mit dem stink normalen Editor. Sollte der Webserver (nicht verwechseln mit Server, da ein Webserver nur eine Software ist, welche auf dem Server läuft) nun diese beiden Dateien erkennen und unterstützen (Provider fragen), so kommt bei den zu schützenden Verzeichnissen stehts eine Login-Abfrage.

Ich z.B. bin bei Strato, dort wird es unterstützt und selbst habe ich nie Probleme damit, ob ich nun irgendwelche Generatoren verwende oder die Dateien selbst per Hand erstelle.
Nun habe ich, wie viele andere hier im Forum auch, das Problem, dass, obwohl Passwort-geschützte Verzeichnisse vorhanden (also im Projekt-Management), bei der Generierung am Ende, diese beiden Dateien einfach nicht erstellt werden.
Da hilft auch nüscht hier und da einzustellen oder externe Generatoren zu nehmen, es ist einfach ein Xpage-interner Fehler. Ich habe es sowohl per FTP-Zugriff, als auch Local probiert. Alte Dateien und Cache zu löschen, bringt an dieser Stelle auch nichts (wär ja auch sinnlos), habe es sicherheitshalber dennoch probiert. Auch habe ich in den Projekteigenschaften die URL hinterlegt.
Selbst bei einem komplett neu erstellten simplen Test-Projekt kommts zum selben Fehler, das Fehlen der Dateien.

Da ich den Xpage-Quellcode nicht kenne, kann ich nicht viel dazu sagen. Ich kann nur sagen, unter welchem System mein Xpage 6.7.1 ausgeführt wird:
Windows 7 Ultimate x64 EN (mit Deutschen Language-Pack)
oder
Windows 7 Ultimate x64 DE

(keine Angst, läuft nicht auf beiden Systemen gleichzeitig, lizenzrechtlich also ok).

-------------------------------------------------------------------------------------------------------------

Zitat

Ich habe mir so beholfen, das ich einen separaten Passwortschutz erzeuge und diesen dann per ftp in den jeweiligen Ordner ablege. Ist zwar etwas auf Umwege, aber es geht. Also kann es nicht am Provider liegen, denn sonst würde es auf diesem Weg auch nicht funktionieren.
Wieder ein Indiz, dass es wohl eher ein Xpage internes Problem ist.
Xpage macht es normalerweise auch so, aber wenn die beiden Dateien fehlen / einfach nicht generiert werden (wohl nicht überall so), so nützt kein Schütteln und kein Klopfen.

Wäre ja mal super, wenn sich ein Xpage-Developer dazu äußern könnte. Als Tester stehe ich gerne zur Verfügung!

Grüße

Schlitzauge :-)
  • Zum Seitenanfang

Sebastian Späth

Support-Team

Beiträge: 219

Xpage-Version: Xpage Internet Studio 6 Professional

Wohnort: Weiden

Betriebssystem: Windows XP

11

Montag, 7. Juni 2010, 14:43

Hallo,

ich habe soeben den Passwort-Schutz getestet - funktioniert.

Die benötigten Daten werden nur beim FTP Upload erstellt, d. h. wenn Sie die Seite lokal fertigstellen, werden die Dateien nicht erstellt. Haben Sie Xpage unter Windows 7 als Administrator gestartet?

Administrator starten:
Rechtsklick auf die Xpage Startexe -> als Administrator starten.

oder

Rechtsklick auf die Xpage Startexe -> Eigenschaften -> Kompatibilität -> die Checkbox "als Administrator starten" aktivieren.

Gruss,
Sebastian Späth
  • Zum Seitenanfang

Schlitzauge

Fortgeschrittener

Beiträge: 38

Xpage-Version: Xpage Internet Studio 6 Professional
Xpage Internet Studio 6 SE
Xpage Internet Studio Shop-Designer

Betriebssystem: Windows XP
Windows 2000
Windows Vista
Linux

12

Samstag, 12. Juni 2010, 23:27

Ja, habe es auch als Admin ausgeführt.
Hm, habs die Tage nochmals probiert und siehe da, es funktioniert, allerdings, wie Sie schon sagten, lediglich per FTP-Zugriff.
Das ganze stört mich allerdings sehr.

Ich verwende nicht den Xpage-internen FTP-Client, sondern FileZilla. Es ist total irreführend, wenn man im Projekt PW-geschützte Verzeichnisse erstellt, diese aber beim lokalen Export (als HTML) nicht PW-geschützt sind.
Nicht jeder verwendet die Xpage-internen Tools, u.a. Bild-Editor oder FTP-Client, sondern Produkte anderer Anbieter, zumal diese wesentlich mehr können. D.h. natürlich nicht, dass Xpage schlecht ist, es heißt nur, dass es für die Zusatz-Tools teils deutlich bessere Alternativen gibt. Für das Kerngebiet ist Xpage meiner MEinung nach aber einzigartig.

Ich finde, eine solche PW-Schutzfunktion sollte unabhängig vom Export-Modus sein, also auch lokal funktionieren. So mancher hat nämlich auch lokal einen Webserver etc. laufen oder exportiert Zwecks der Einfachheit lieber lokal und lädt dann mit einem Dritthersteller-FTP-Programm die Daten hoch. Hier sollte man schleunigst nachhelfen. Die beiden benötigten Dateien sollten wenigstens generiert werden, egal ob via FTP oder Lokal exportiert wird, zudem sollte in der Hilfe stehen, was die derzeitige Bedingung für PW-Schutz ist.
Es wäre auch super, wenn man Xpage demnächst noch so umprogrammieren könnte, ohne es jedesmal als Admin ausführen zu müssen.

Mit freundlichen Grüßen

Schlitzauge :-)
  • Zum Seitenanfang

Kramkiste

Einsteiger

Beiträge: 15

Xpage-Version: Xpage Internet Studio 6 Professional

Wohnort: Hamburg

Betriebssystem: Windows Vista

13

Mittwoch, 26. Januar 2011, 21:10

Hallo,

ich habe das nun auch schon seit einiger Zeit versucht einen Passwortgeschützen Ordner zu erstellen, leider ohne Erfolg.
Bisher habe ich alles selbst mit Filezilla hochgeladen, aber dann hab ich es einmal mit dem Auto.Upload versucht. Dort kommt dann die Fehlermeldung, dass htaccess nicht erstellt werden konnte und der Upload bricht ab...

Was kann ich nun machen?

MfG
Anna
  • Zum Seitenanfang

Martin Fehse

Fortgeschrittener

Beiträge: 40

Xpage-Version: Xpage Internet Studio 6 Professional

Wohnort: Freiburg

Betriebssystem: Windows XP
Windows 2000
Windows Vista
Windows 7

14

Donnerstag, 27. Januar 2011, 07:14

Funzt doch !

Hallo zusammen,

mit Sicherheit liegt das Problem nicht an Xpage. Ich habe schon sehr viele passwortgeschützte Bereiche erstellt und alle funktionieren einwandfrei. Aus eigener Erfahrung liegt das Problem eben doch am Webpaket und an den eingestellten Projekteigenschaften. Wenn im Webpaket die dynamischen Inhalte fehlen, wie z.B. php-Scripte, dann wird der Upload von .htacess und .htpwd01 auch nicht funktionieren, da diese vom Provider abgelehnt werden.

Also Webpaket auf dynamische Inhalte überprüfen
Richtige URL in den Projekteigenschaften prüfen
Geschützte Bereiche immer in einem Ordner anlegen, dann den Ordner schützen. Nach dem Upload müssen beide o.g. Dateien in diesem Ordner vorhanden sein. Ist dies nicht der Fall, unterstützt das Webpaket keine dynamischen Inhalte. Dann heißt es das Paket entsprechend zu erweitern.

Gruß aus Freiburg
Martin Fehse
  • Zum Seitenanfang

Ähnliche Themen