Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen beim Xpage Anwender-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Beiträge: 6

Xpage-Version: Xpage Internet Studio 6 Professional

Betriebssystem: Windows 8

1

Sonntag, 15. Februar 2015, 14:46

Formular drucken

Hallo,

ich möchte, dass das ausgefüllte Formular nicht nur per E-Mail versandt wird, sondern zusätzlich vom Ausfüllenden ausgedruckt werden kann. Hierzu habe ich die Eigenschaft Formular mailen eingesetzt, was auch funktioniert. Auf die gleiche Weise habe ich die Eigenschaft "drucken" angesteuert. Leider funktioniert dies nicht. Weiß jemand, was ich falsch gemacht haben könnte?

Viele Grüße
Wilfried
  • Zum Seitenanfang

Enrico1705

Experte

Beiträge: 260

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Kärnten

Betriebssystem: Windows 7

2

Montag, 16. Februar 2015, 11:29

Hallo Wilfried,
als ich habe jetz mal bei einem Projekt von mir in ein Formular einen "Systembutton" eingefügt und die Aktion "Drucker" vergeben.
Es funktioniert ganz normal. Es kommt nach dem Klick auf den Button die Druckerauswahl, lediglich die Seitenansicht muss man halt anpssen vor dem Druck damit auch alles drauf ist.
Vielleicht haben sie nur einen normalen Button genommen, das habe ich nicht probiert!
Hoffe es funkioniert dann auch bei Ihrer seite.
MfG Enrico1705

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Enrico1705« (17. Februar 2015, 18:06)

  • Zum Seitenanfang

Beiträge: 6

Xpage-Version: Xpage Internet Studio 6 Professional

Betriebssystem: Windows 8

3

Montag, 16. Februar 2015, 17:57

Formular drucken

Hallo Enrico,

danke für Ihre Antwort. Als ich diese nachvollziehen wollte, habe ich festgestellt, dass ich das Projekt wohl irrtümlich nicht gespeichert habe. Die Seite liegt nun auf dem FTP-Server. Ich wollte sie herunterladen, und habe eine html-Datei auf dem Desktop mit einigen Hyroglyphen erhalten. Wie kann ich denn den Download machen, so dass die Seite in mein Projekt integriert wird? Hast Du damit Erfahrung?

Viele Grüße
Wilfried
  • Zum Seitenanfang

Enrico1705

Experte

Beiträge: 260

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Kärnten

Betriebssystem: Windows 7

4

Dienstag, 17. Februar 2015, 18:20

Hallo Wielfried,
ich verstehe nicht ganz, was heißt du hast

Zitat

...das Projekt wohl irrtümlich nicht gespeichert...
? Hast du nirgends am PC die Projektdatei?! Es gibt einen Backupordner von Xpage worin in gewissen Abständen die Projektdaten gespeichert werden, der Pfad ist in Xpage unter "Extras" & Einstellungen "Auto Backup" zu finden. Vielleicht ist dort noch ein Backup von deinem Projekt!
Wie meinst du das

Zitat

Ich wollte sie herunterladen, und habe eine html-Datei auf dem Desktop mit einigen Hyroglyphen...
? Wenn du die Datei vom Server herunterlädst (z.B. mit FilleZilla) dann mußt du auch alle von XPage erstellten Ordner auch herunterladen. Nur hast du dann natürlich nur html Seiten welche mit XPage nicht mehr zu bearbeiten sind. Dafür braucht man ein anders Programm, z.B Frontpage von Microsoft od.äh. ist aber sehr mühselig!
Also geht meines Wissens es nicht, dass ich einen html Datei in ein Projekt einbinde, auße in einen OLE Container als externen Link!
Ich habe bei meinen Projekten immer am Server einen extra Ordner erstellt worin ich die Projektdatei zusätzlich hochlade, als Sicherheit!
MfG Enrico1705
  • Zum Seitenanfang

Beiträge: 6

Xpage-Version: Xpage Internet Studio 6 Professional

Betriebssystem: Windows 8

5

Mittwoch, 18. Februar 2015, 14:53

Dateien-Management

Hallo Enrico,

danke für Deine Hinweise. Sie haben mir sehr geholfen. Mit dem Druck-Button war eigentlich auch alles in Ordnung. Man musste nur mit der Maus ein wenig navigieren.

Beste Grüße
Wilfried
  • Zum Seitenanfang

Ähnliche Themen