Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen beim Xpage Anwender-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

sera1711

Einsteiger

Beiträge: 6

Xpage-Version: Xpage Internet Studio 7 SE

Wohnort: Berlin

Betriebssystem: Windows 7

1

Mittwoch, 20. November 2013, 13:29

Fertiggestelltes Projekt auf Webspace hochladen

hallo, ich habe mein projekt fertig und habe folgendes problem. ich habe bereits eine website also eine domain bei greatnet und möchte diese alte website austauschen mit der neuen die ich über xpage gemacht habe. wie geht das, wie mach ich das? wer kann mir helfen??

grüße, sera
  • Zum Seitenanfang

juergen

Routiner

Beiträge: 84

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Frechen bei Köln

Betriebssystem: Windows 8

2

Mittwoch, 20. November 2013, 19:18

Sollen die alten Seiten gelöscht werden und durch die neuen ersetzt werden, dann geht folgender Weg:
Dem FTP-Client die Daten des Providers für die entsprechende bestehende Homepage-Adresse eingeben.
Den FTP-Cleinet starten und die alten Dateien beim Provider löschen.
Den FTP-Client beenden.
In Xpage die Funktion Auto-Upload anklicken auf der Maske Projekt fertig stellen und die entsprechende dazu gehörende FTP-Verbindung anklicken und unten rechts auf Hochladen klicken.
Warten bis die Übertragung beendet ist und danach stehen die neuen Seiten im Internet zur Verfügung.
Vielleicht hilft dieser Hinweis.
Herzliche Grüße Jürgen
  • Zum Seitenanfang

sera1711

Einsteiger

Beiträge: 6

Xpage-Version: Xpage Internet Studio 7 SE

Wohnort: Berlin

Betriebssystem: Windows 7

3

Montag, 25. November 2013, 16:06

vielen dank für die antwort jürgen!! muss ich denn wenn ich das FTP program geöffnet habe ALLe alten dateien ( z.B. ordner wie: configs, atd, files...html) komplett löschen? und dann versteh ich nicht was ich in der xpage maske : name, server, port und startverzeichnis eingeben muss...

grüße
sera
  • Zum Seitenanfang

juergen

Routiner

Beiträge: 84

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Frechen bei Köln

Betriebssystem: Windows 8

4

Montag, 25. November 2013, 17:07

Wenn die alten Dateien nicht komplett gelöscht werden, kann (muss aber nicht unbedingt) es mit den neu übertragenen Dateien zu einem Konflikt kommen wenn sie gemeinsam im gleichen Verzeichnis stehen..
Beim automatischen Upload legt Xpage alle nötigen Verzeichnisse selbst an.

Wenn die alten Dateien archiviert werden sollen zu einer evtl. späteren Verwendung, können diese auch vom Provider auf den eigenen Rechner herunter geladen werden. Dann sind sie später wieder im Fall der Fälle manuell rückladbar.

Sind die früheren Homepage-Seiten mit Xpage erstellt worden, sollte diese Datei für den Fall der Fälle auf dem eigenen Rechner archiviert werden. Dann ist jederzeit eine Rückkehr möglich.

Jetzt zu den Fragen zum eintragen auf der Xpage-Maske des FTP-Clienten:

Name: z.B. den Namen der Homepage eintragen ohne www. und ohne .de
Server: hier muss der Server des Providers eingetragen werden (in den Unterlagen des Providers nachsehen bzw. bei diesem anfragen! Bei Strato z.B. ftp.strato.com. ACHTUNG! Ist Provider spezifisch!
Port: ist mit 21 - vorbelegt und kann meistens bleiben
Benutzername: den Namen der Homepage mit kompletter URL z.B. www.rosengarten.de
Passwort: das beim Provider hinterlegte Passwort des Zugangs zum FTP-Server.
Startverzeichnis: / den Backslash stehen lassen oder eintragen - d.h. Xpage ordnet beim automatischen Upload die neuen Verzeichnisse im Grundverzeichnis an.
Beschreibung: Kurzbeschreibung der Homepage

Ich hoffe, das ich helfen konnte.

Herzliche Grüße Jürgen
  • Zum Seitenanfang

sera1711

Einsteiger

Beiträge: 6

Xpage-Version: Xpage Internet Studio 7 SE

Wohnort: Berlin

Betriebssystem: Windows 7

5

Dienstag, 26. November 2013, 07:55

hallo jürgen, es klappt nicht. irgendwas mach ich wohl falsch. ich habe jetzt das projekt im FTP program aus dem localen system auf die rechte seite also dem remote system in den html ordner übertragen. aber auch dann wird das neue projekt nicht online angezeigt. so langsam fällt mir nichts mehr ein
  • Zum Seitenanfang

juergen

Routiner

Beiträge: 84

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Frechen bei Köln

Betriebssystem: Windows 8

6

Dienstag, 26. November 2013, 08:17

Die Übertragung sollte mit dem Xpage eigenen FTP-Programm im "AUTO-Upload" erfolgen!

Lässt sich durch Anwahl des FTP-Client unter Ansicht und anklicken der entsprechenden Verbindung Kontakt zum Provider aufnehmen?
Erscheinen auf der rechten Seite in den vorher leeren Feldern Ordner und Dateien? Dann sind die Parameter richtig eingestellt.

Der AUTO-Upload-Ablauf ist folgender:

Das Programm wird gestartet durch anklicken des ICON "Generiert einen Webauftritt" (eine kleine farbige Kugel als Symbol oben in der ICON-Leiste - meistens ganz rechts).
Dann folgt die Maske "Projekt fertig stellen"
Knapp oberhalb der Mitte sind 2 Reiter. Auf Datenträger ist aktiviert, aber bitte rechts daneben Auto-Upload anklicken.
Dann die vorher angelegte FTP-Verbindung im Feld unter FTP-Verbindungen anklicken.
Unten rechts "Hochladen" anklicken
Unter Konsole ist die Übertragung zu verfolgen.

Wenn auf der der Konsole unten "Vorgang erfolgreich" angezeigt wird, ist die Homepage im Internet erreichbar.

Gruss Jürgen
  • Zum Seitenanfang

juergen

Routiner

Beiträge: 84

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Frechen bei Köln

Betriebssystem: Windows 8

7

Dienstag, 26. November 2013, 08:44

Ich weiß nicht, ob es mit der SE-Version überhaupt möglich ist per AUTO-Upload die Dateien als html zu übertragen.

Diese Version kenne ich leider überhaupt nicht und kann daher auch nichts dazu sagen.

Was ich beschrieben habe bezieht sich immer auf die Vollversion, denn nur mit dieser arbeite ich.

Wenn es nach meiner Beschreibung nicht funktioniert, müsste bitte ein Fachmann, der die SE-Version" kennt weiterhelfen!

Herzliche Grüße von Jürgen
  • Zum Seitenanfang

sera1711

Einsteiger

Beiträge: 6

Xpage-Version: Xpage Internet Studio 7 SE

Wohnort: Berlin

Betriebssystem: Windows 7

8

Dienstag, 26. November 2013, 09:14

hallo jürgen, hat geklappt danke!!!

noch eine letzte frage an dich: wie aktualisiere ich die website wenn ich änderungen im xpage vornehme?

lieben gruß
sera

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »sera1711« (26. November 2013, 15:37)

  • Zum Seitenanfang

juergen

Routiner

Beiträge: 84

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Frechen bei Köln

Betriebssystem: Windows 8

9

Donnerstag, 28. November 2013, 11:44

Hallo Sera,

Das freut mich, dass es jetzt endlich funktioniert.
Ich konnte mir erst heute den Eintrag ansehen und mit einem von meinen vergleichen. Dabei fiel mir auf, dass es da keine Zeile mit einem Hinweis auf den "Passivmode" gibt wie bei mir.

War das möglicherweise die Ursache? Oder was sonst?

Zur Frage:

Einfach die geänderte(n) Seite(n) mit Auto-Upload neu übertragen. dann werden sie beim Provider überschrieben und aktualisiert.

Herzliche Grüße Jürgen.
  • Zum Seitenanfang

Ähnliche Themen