Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen beim Xpage Anwender-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

teddyg

Einsteiger

Beiträge: 12

Xpage-Version: Xpage Internet Studio 6 Professional

Betriebssystem: Windows XP

1

Samstag, 30. Juli 2011, 13:42

Videobox zentrieren

Hallo,

habe ein Problem mit der Videobox 1.1.

Sie erscheint vertikal nicht zentriert. Im IE ist sie sogar ganz oben an

der IEleiste angeklatscht. Das kann man doch im Script irgendwie verändern, oder?



Hier das Script:

body {margin: 0;}

#lbOverlay {

position: absolute;

left: 0;

width: 100%;

background-color: #000;

cursor: pointer;

}

#lbCenter, #lbBottomContainer {

position: absolute;

left: 50%;

overflow: hidden;

background-color: #fff; text-align: center; padding: 5px;

}

.lbLoading {

background: #fff url(loading.gif) no-repeat center;

}

#lbImage {

border: 10px solid #fff;

}

#lbPrevLink, #lbNextLink {

display: block;

position: absolute;

top: 0;

width: 50%;

outline: none;

}

#lbPrevLink {

left: 0;

}

#lbPrevLink:hover {

background: transparent url(prevlabel.gif) no-repeat 0% 15%;

}

#lbNextLink {

right: 0;

}

#lbNextLink:hover {

background: transparent url(nextlabel.gif) no-repeat 100% 15%;

}

#lbBottom {

font-family: Verdana, Helvetica, sans-serif;

font-size: 10px;

color: #666;

line-height: 1.4em;

text-align: left;

border: 5px solid #fff;

border-top-style: none;

}

#lbCloseLink {

display: block;

float: right;

width: 66px;

height: 22px;

background: transparent url(closelabel.gif) no-repeat center;

margin: 5px 0;

}

#lbCaption, #lbNumber {

margin-right: 71px;

}

#lbCaption {

font-weight: bold;

}





Ich finde nur leider nix. Nach links und rechts kann ich sie problemlos

verschieben. Nur eben nicht nach oben und unten!



Kann mir da jemand helfen?

Vielen Dank

teddyg

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »teddyg« (1. August 2011, 11:40)

  • Zum Seitenanfang

Achim Fricke

Experten-Team

Beiträge: 1 096

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 6 Professional

Wohnort: in Schleswig-Holstein Nähe Hamburg

Betriebssystem: Windows 7

2

Sonntag, 7. August 2011, 11:14

Hi teddyg,

so ganz kann ich Ihr Problem nicht nachvollziehen: Sie binden Videobox doch sicher über einen OLE ein, oder? Und den können Sie doch positieren und zentrieren wie Sie wollen.

Gruß
Achim Fricke
  • Zum Seitenanfang

derdj

Routiner

Beiträge: 78

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 6 Professional

Betriebssystem: Windows 8
Windows 7

3

Sonntag, 7. August 2011, 11:50

Hi
teddyg,

vergleiche
Dein und diesen Code-Fetzen, und erweitere style Datei um fehlende
Angaben für „Höhe“ bzw selfhtml.org unter tag style durchlesen.
Es ginge auch mit „padding-top:xpx;“




<iframe
name="shop_control" src="shop/session.php"
frameborder="0" style="position:absolute;
top:0px;left:0px; border:0px; width:1px;
height:1px"></iframe>



<td
style="font-size:8pt;padding-left:2px;font-weight:bold;color:gray;"
height="20" colspan="5" align="left"
valign="top"
bgcolor="#ffffff">


Grüße

derdj
  • Zum Seitenanfang

teddyg

Einsteiger

Beiträge: 12

Xpage-Version: Xpage Internet Studio 6 Professional

Betriebssystem: Windows XP

4

Sonntag, 7. August 2011, 13:00

Danke für die Antwort,



mir raucht der Schädel. :-) Meinst du in der .css Datei? Da gibts irgendwie kein iframe.

Wenn ich unter#IbCenter padding-top: z.B.:100px eingebe, wird die Videobox dünner??????? :-)

Sorry, echt Anfänger darin.



Gruß

teddyg
  • Zum Seitenanfang

derdj

Routiner

Beiträge: 78

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 6 Professional

Betriebssystem: Windows 8
Windows 7

5

Sonntag, 7. August 2011, 14:59

Hi teddyg,
immerhin ein Anfang, Du hast was im Code verändert und sogar die Änderung sehen können. Versuche :
#lbCenter, #lbBottomContainer {

position: absolute;


top:10px;

left: 50%;

overflow: hidden;

background-color: #fff; text-align: center; padding: 5px;

}
oder :
#lbCenter, #lbBottomContainer {

position: absolute;


valign:center;

left: 50%;

overflow: hidden;

background-color: #fff; text-align: center; padding: 5px;

}
oder, oder,oder.
Du hast Code-Fetzen geschickt und ich gehe davon aus dass das teil eine css ist oder teil eines style tags. Deshalb die Empfehlung auf www_selfhtml.org style tag durchzulesen und eben schreib-weise der Attribute im Code.
Die Code-Fetzen von mir sollten nur als Beispiel dienen wie man ungefähr die Höhe beeinflusst. In Deinem Code gibt’s keine Angaben uber Höhe, hight:100%; oder änliches, und wenn diese angaben fehlen, oder wenn Platzhalter zu klein ist kommt zu diesem nach oben klatschen. Du solltest erkennen dass im Code nach position: absolute; ein Attribut top:10px; oder valign:center; hinzugefügt werden kann um Darstellung zu ändern. Welcher Attribut und wo die Richtige Stelle ist, kann ich nicht sagen, ich müsste selber rumfrickeln.
Grüße
derdj
  • Zum Seitenanfang

teddyg

Einsteiger

Beiträge: 12

Xpage-Version: Xpage Internet Studio 6 Professional

Betriebssystem: Windows XP

6

Sonntag, 7. August 2011, 16:36

Hi derdj,

das ist die tatsächliche .css Datei von der Videobox 1.1. Die ich auch 1 zu 1 übernommen habe (bis auf kleine Farbänderungen).

Die fehlende Höhenangabe hat mich auch irritiert. Da das Script auf der Slimbox basiert, und die 1a akurat in der Mitte sitzt, dachte ich es würde genauso

funktionieren. Tut es aber nicht. Jetzt hab ich alle Varianten nach deinen Angaben ausprobiert und das Ding will net.



Siehe: www.ababiri.de unter Filme



Trotzdem schonmal vielen Dank für deine Bemühungen! Super nett!



LG

teddyg
  • Zum Seitenanfang

derdj

Routiner

Beiträge: 78

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 6 Professional

Betriebssystem: Windows 8
Windows 7

7

Montag, 8. August 2011, 09:59

Hi teddyg,
hab die Seite angeschaut, und ich kann nicht nachvollziehen was für Dich nach oben geklatscht heißt. Video-Fenster befindet sich 60,xxx px (echt krumme Zahl) von oben, und wenn dass das ist ?
<div style="width: 640px; height: 480px; margin-left: -320px; top: 61.4667px; .....
Grüße derdj
  • Zum Seitenanfang

derdj

Routiner

Beiträge: 78

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 6 Professional

Betriebssystem: Windows 8
Windows 7

8

Montag, 8. August 2011, 11:59

Hi teddyg,

ich war nicht faul und hab mir die
Seite unter IE angeschaut und in der tat klebt das Ding ganz oben.

Das sind Darstellungs-Unterschiede zw.
IE und Rest der Welt.


Es ist zu beheben.

Die „Losung“ ist diese Code-Zeile,
Bzw. ein teil davon:


<div style="width: 640px; height: 480px; margin-left: -320px; top: 61.4667px; background: none repeat scroll 0% 0% rgb(255, 255, 255);" id="lbCenter">
<embed type="application/x-shockwave-flash" src="http://www.youtube.com/v/hQuKa5_UX_Y" style="" id="flvvideo" name="flvvideo" quality="high" wmode="transparent" width="640" height="480">

</div>

Was und wie genau kann ich erst sagen
wenn Du kurze Beschreibung wie Du das alles aufgebaut hast, da der
Quell-Code nicht alles sagt, gepostet hast, zB. Button als hyperlink
zu youTube, aber Target nicht gewählt, die Dateien im Ordner files
wurden im OLE als Code durch Editor eingefügt, oder per Drag und
Drop usw.


IE benötigt konformes „Style“
Programmieren, als Unterschied zum FF. Wenn die Angaben für höhe
und breite fehlen, macht IE was er will. Diese Angaben werden im
body-tag bei Dir, vermisst.


Grüße

derdj
  • Zum Seitenanfang

teddyg

Einsteiger

Beiträge: 12

Xpage-Version: Xpage Internet Studio 6 Professional

Betriebssystem: Windows XP

9

Dienstag, 9. August 2011, 16:47

Hallo derdj,

Im Head(zusätzlich im Head) steht:

<script type="text/javascript" src=files/js/videobox.js"></script>

<link rel="stylesheet" href="files/css/videobox.css" type="text/css" media="screen"



Der erste Button(Thumbnail) hat z.B: folgenden Hyperlink bei Mausklick: http://www.youtube.com/watch?v=hQuKa5_UX_Y" rel="vidbox 640 480"title="Für Dich"



Und die Dateien (css,inkl. Bedienbilder ) liegen unter files, "css".

Die Js Dateien liegen unter files, "js".



Dort liegen aber auch die css und js Dateien der Slimbox. Kanns eventuell sein das sich das beisst?



Wo die Zahl " 61.447px" herkommt ist mir ehrlich gesagt völlig schleierhaft. Ich kann die wenn ich den Quelltext der Seite öffne auch gar nicht finden. Komisch. Mann ist das kompliziert! Ich glaub ich bleib lieber bei meinem 3D Kram.



Vielen Dank für deine Mühe

LG

teddyg

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »teddyg« (9. August 2011, 16:56)

  • Zum Seitenanfang

derdj

Routiner

Beiträge: 78

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 6 Professional

Betriebssystem: Windows 8
Windows 7

10

Mittwoch, 10. August 2011, 11:46

Hi teddyg,

es ist so:

  • diese Code-Zeile wird von Videobox
    erstellt nach dem Videoladen, und wird nicht von IE verarbeitet.
    Angabe top: 61.446px wird von FF4 angezeigt, und unter FF5 sind das
    rund 61px.
  • Alles was blau ist ist ein style
    tag in einem div tag und grau sind dann Inhalte je Button den Du
    erstellt hast

  • Beim Button als Hyperlink zu
    YouTube hast Du kein Target vorbestimmt, und in diesem Fall

    wird Videobox mit Hilfe vom Javascript
    im files Ordner mit diesem Überblendungseffekt als
    „Meldung“(übergeordneter Frame) gestartet (FF) was bei IE
    total weg-fällt.
  • Die Angabe (blau im Code-Zeile –
    siehe oben) verweist auf Element id=“lbCenter“ und nicht auf
    Element #lbCenter, #lbBottomContainer{..... was von Dir gepostet
    wurde
  • Suche im css nachm Eintrag
    #lbCenter{.... und ergänze die top Angabe oder
  • erstelle in der Seite ein OLE und
    bestimme ihn als target beim Button zu YouTube, siehe Hilfe vom
    xpage - OLE bzw im shop-tutorial darstellen von Warenkorb-Inhalt,
    bzw. hier in Forum unter Tutorials, da geht es um Slimbox oder so.



Grüße


derdj

PS
Versuch hier ganz am Anfang
Hier das Script:

body {margin: 0;}

#lbOverlay {

position: absolute;

left: 0;


top:61px;

width: 100%;

background-color: #000;

cursor: pointer;

}

#lbCenter, #lbBottomContainer {

position: absolute; ….....

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »derdj« (10. August 2011, 11:52)

  • Zum Seitenanfang

teddyg

Einsteiger

Beiträge: 12

Xpage-Version: Xpage Internet Studio 6 Professional

Betriebssystem: Windows XP

11

Donnerstag, 11. August 2011, 16:57

Hi derdj,

tausend Dank für deine Hilfe.

Werd das alles nochmal probieren. Zur Not gehen dann die Videos nicht mehr mit der Videobox auf, sondern ganz einfach im OLE.

Sieht dann halt nicht mehr so schick aus. Anders bekomm ichs halt momentan nicht hin. Muß mich auch jetzt erstmal um andere Sachen kümmern.



Liebe Grüße

teddyg
  • Zum Seitenanfang

Ähnliche Themen