Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen beim Xpage Anwender-Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

d.schäfer

Einsteiger

Beiträge: 10

Xpage-Version: Xpage Internet Studio 7 Professional

Betriebssystem: Windows 8

1

Donnerstag, 20. Januar 2011, 11:49

Formular lässt sich nicht über Button abschicken

Hallo in die Runde,
komme selbst leider nicht mehr weiter mit folgendem Problem:
Ich habe ein (mein erstes!) Formular erstellt (www.dorotheeschaefer.de unter Anmeldung) und der Sende Button reagiert nicht.
Meine Vorgehensweise :
- Formular angelegt
- Button eingefügt
- Ebenen definiert
- Aktion "bei Druck Maustaste" mit Formular mailen belegt
- Email, Betreff, Rückmeldung als Text ausgefüllt
- Auto-Upload (war erfolgreich)

Das Formular ist zu sehen, eintragen lässt sich auch alles, aber abschicken geht nicht.
Nach sorgfältiger Durchsicht dieses Forums habe ich die vergangenen 2 Stunden hiermit verbracht:

- Überprüfung, ob mein Anbieter/ mein Paket php hat, Ergebnis: hat er: php 4.4.9 und php 5
- Das ganze Formular noch mal neu geschrieben: Ergebnis: keine Veränderung
- Unter Projekteigenschaften die URL geprüft: die stimmt

Jetzt gehen mir die Ideen aus und ich hoffe, ihr habt noch welche.
Herzliche Grüße
Dorothee Schäfer
  • Zum Seitenanfang

Achim Fricke

Experten-Team

Beiträge: 1 096

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 6 Professional

Wohnort: in Schleswig-Holstein Nähe Hamburg

Betriebssystem: Windows 7

2

Donnerstag, 20. Januar 2011, 16:07

Hi, d.schäfer,

- Bietet der Tarif bei Ihrem Internetplatzanbieter PHP?
- Bitte beschreiben Sie genau, was - nach vollständigem Ausfüllen des Formulars - passiert, wenn Sie den Sendebutton drücken.
- Haben Sie im Formular "Mussfelder" definiert? Und dise durch Fehleroverlays für den Fall abgesichtert, dass die Bedingung beim Ausfüllen nicht erfüllt wird ? (Wenn nicht: ist auf jeden Fall empfehlenswert und hilft auch bei der Fehlersuche ;-).)

Gruß
Achim Fricke
  • Zum Seitenanfang

d.schäfer

Einsteiger

Beiträge: 10

Xpage-Version: Xpage Internet Studio 7 Professional

Betriebssystem: Windows 8

3

Donnerstag, 20. Januar 2011, 20:18

Hallo Herr Fricke,
vielen Dank für die Ideen!

- Theoretisch habe ich einen Tarif mit php (PHP4, 5, 6beta) (1&1 hompage Basic). Praktisch weiß ich das leider nicht. Ich habe nämlich keine Idee, mit welchem Programm ich eine php-Datei erstellen kann (habe den Tipp mit <?php phpinfo(); ?> als php-Datei hochladen gelesen), mit Word-Pad als Text-Editor geht das bei mir nicht.

- Es passiert gar nichts! Ich habe die Ebenen des Buttons unterschiedlich eingefärbt, um zu sehen, was passiert (Ausgangszustand blau, Mausberührung Schrift grün, Mausklick Button grün): Mausberührung findet statt (Schrift grün sieht man), bei Mausklick ist nix, d.h. Button bleibt blau, Schrift grün.

- Ja, ich habe Mussfelder definiert und einige auch auf nummerisch eingegrenzt. Meine Anmeldeprobe habe ich mit echten Daten gemacht, deswegen kann es eigentlich kein Eingabefehler sein. Ich werde mich mal an die Fehleroverlays machen, dann weiß ich hoffentlich mehr. Habe mir gerade die Hilfe dazu angeschaut, bitte nicht wundern, wenn ich mich länger nicht melde;-)

Vielen Dank erst einmal ich melde mich, wenn ich auf Neuigkeiten stoße (im Guten, wie im Schlechten;-)
Dorothee Schäfer
  • Zum Seitenanfang

Achim Fricke

Experten-Team

Beiträge: 1 096

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 6 Professional

Wohnort: in Schleswig-Holstein Nähe Hamburg

Betriebssystem: Windows 7

4

Donnerstag, 20. Januar 2011, 22:57

o.k., Dorothee;

War ja nur ein erster Versuch ;-), so schnell geben wir nicht auf.
Wenn Sie mögen, dann mailen Sie mir mal die Projektdatei, damit ich mir das Formular im Original ansehen kann.

Grüße
Achim Fricke
  • Zum Seitenanfang

d.schäfer

Einsteiger

Beiträge: 10

Xpage-Version: Xpage Internet Studio 7 Professional

Betriebssystem: Windows 8

5

Freitag, 21. Januar 2011, 12:55

Lieber Achim Fricke,

die Overlays und ich sind Freunde geworden;-) Es ist geglückt und zu bewundern unter oben angegebenem Link.

Es war das Textfeld Postleitzahl und an dieser Stelle können Sie vielleicht aus meinem letzten Häh- noch ein Aha-Erlebnis machen:

Ich hatte das Feld - um genau 5 Ziffern zuzulassen - folgender Maßen eingegrenzt:
Mussfeld
nummerisch
min: 5
max: 5

Seit ich die Min/Max-Werte rausgenommen habe funktioniert es. War das von mir falsch gedacht oder haken wir das unter den Eigenwilligkeiten der 0/1-Welt ab?

Ganz herzlichen Dank für Ihre Unterstützung und Ihr Projektdateien-Anguck-Angebot. Das spar ich mir auf, ich fürchte es gibt ein nächstes Mal;-)
Viele Grüße
Dorothee
  • Zum Seitenanfang