Sie sind nicht angemeldet.

schmidt.rb

Einsteiger

Beiträge: 6

Xpage-Version: Xpage Internet Studio 6 Professional

Betriebssystem: Windows 7

1

Montag, 19. September 2016, 17:41

Seiteneigenschaften Aufrufprobleme

Hallo,
das Menue "Seiteneigenschaften" lässt sich in einem Projekt (300 Seiten) nur noch sehr widerwillig aufrufen. Es klappt nur wenn das Projekt neu geladen ist, oder nicht viel unternommen wurde. Ansonsten erfolgt nach dem Aufruf keine Reaktion.
Gibt es eine Möglichkeit das zu ändern ? XP 7.
Danke
Roland
  • Zum Seitenanfang

Enrico1705

Experte

Beiträge: 260

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Kärnten

Betriebssystem: Windows 7

2

Dienstag, 27. September 2016, 15:39

Hallo Roland,

vielleicht liegt es am Hauptspeicher von XPage, hatte auch mal ein ähnliches Problem.
Versuch mal diesen Tipp:

Tipp: Hauptspeicher für Xpage erhöhen
Wenn Xpage-Projekte größer werden, kann Xpage langsamer werden. Das Programm hat dann zu wenig Speicher. In diesem Fall kann man Xpage einfach mehr Speicher zuweisen und die Anwendung läuft wieder performanter. Die Einstellung steht in einer Konfigurations-Datei im Xpage-Programmverzeichnis. Hier muss man nur eine Zahl ändern, das ist alles. So gehts:
1. Beenden Sie Xpage.
2. Klicken Sie das Xpage-Desktop-Icon mit Rechtsklick an und wählen Sie im Kontextmenü 'Dateipfad öffnen' aus.
3. Öffnen Sie die VMOPTIONS-Datei 'XpageInternetStudio 7' (1 KB) mit dem Windows-Editor.
4. Entfernen Sie in Zeile 3 das # Zeichen und ersetzen Sie die Zahl 512
durch 2048, um den maximalen Speicher von 512 MB auf 2 GB zu erhöhen.
5. Speichern Sie die Änderungen ab und starten Sie Xpage neu.

Vorher:
# Enter one VM parameter per line
# For example, to adjust the maximum memory usage to 512 MB, uncomment the following line:
# -Xmx512m
# To include another file, uncomment the following line:
# -include-options [path to other .vmoption file]


Nachher:
# Enter one VM parameter per line
# For example, to adjust the maximum memory usage to 512 MB, uncomment the following line:
-Xmx2048m
# To include another file, uncomment the following line:
# -include-options [path to other .vmoption file]

Vielleicht hilf es ja!
LG Enrico1705
  • Zum Seitenanfang

schmidt.rb

Einsteiger

Beiträge: 6

Xpage-Version: Xpage Internet Studio 6 Professional

Betriebssystem: Windows 7

3

Dienstag, 18. Oktober 2016, 12:22

Hallo Enrico,
das ist natürlich der beste Tipp - und es funktioniert.

Ein kleine Änderung, die Datei beginnt mit 7.
Ansonsten geht nun alles schneller und ich muss nicht mehr mit den Grafiken geizen.

Herzlichen Dank, das hat mir wirklich geholfen.

Gruss
Roland
  • Zum Seitenanfang

Mr. President

Experten-Team

Beiträge: 20

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Schleswig-Holstein

Betriebssystem: Windows 7
Linux

4

Dienstag, 3. Januar 2017, 15:05

Er funktioniert in der Tat, hatte ich gar nicht gewußt.
Aber wirklich schneller ist die Software dadurch auch nicht.


Gruß Mr. President
  • Zum Seitenanfang

Enrico1705

Experte

Beiträge: 260

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Kärnten

Betriebssystem: Windows 7

5

Mittwoch, 4. Januar 2017, 00:01

Hallo Mr. President,
kann den Ärger/Negativeinstellung ja verstehen.
Aber bei mir läuft es seit der Speichererweiterung flüssiger, das ist eigentlich das was, meiner Meiung nach,damit bezweckt werden sollte.
MfG Enrico1705
  • Zum Seitenanfang

Mr. President

Experten-Team

Beiträge: 20

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Schleswig-Holstein

Betriebssystem: Windows 7
Linux

6

Mittwoch, 4. Januar 2017, 10:04

Alles gut, mein Kommentar war keineswegs negativ gedacht.
Und endlich mal ein Tipp den selbst ich noch nicht kannte ;-))

Hast Du einen Workaround bzgl. Textumlauf? Im Editor sieht alles perfekt aus, doch im Browser werden Teile von Sätzen in die nächste Zeile verschoben.
Ungabhängig davon ob der Text links, oben, rechts oder unter dem Bild läuft.... auch die Abstände verringern auf 0 bringt keine Änderung. Wenn dieser
Bug nicht wäre, könnte ich mich anfreunden doch noch bei Xpage zu bleiben. Gleiches glt für den Counter, er wird dargestellt, aber ohne Inhalt. Einfach
nur ein farbiger Kasten ohne Zähler. Auch hier werde ich wohl auf ext. Code zurückgreifen müssen.


Gruß Mr. President
  • Zum Seitenanfang

Enrico1705

Experte

Beiträge: 260

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Kärnten

Betriebssystem: Windows 7

7

Donnerstag, 5. Januar 2017, 10:23

Hallo Mr. President,

ja das ist mir auch schon ein paar mal aufgefallen das der Text dann im Netz verschoben ist (bzw. bei der Vorschau). Da muss man leider ein wenig improvisieren.
Den Counter habe ich noch nie verwendet, kann also nicht dazu sagen.
Auch mit den Anführungszeichen gibt es immer Probleme. Wenn man einen Text aus z.B. einem Word importiert und dort die Anführungszeichen unten sind wird es im Netz als &Quote (od.so. äh.) dargestellt. D.h. die Anführungszeichen dürfen erst nach dem Import in X_page gesetzt werden damit sie richtig angezigt werden. Ist auch lästig, aber wenn man es weiß- darf halt keines übersehen!

LG Enrico1705
  • Zum Seitenanfang

Mr. President

Experten-Team

Beiträge: 20

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Schleswig-Holstein

Betriebssystem: Windows 7
Linux

8

Freitag, 6. Januar 2017, 18:24

Das Problem des Counters habe ich extern über [url]www.counterservice.de[/url] gelöst, funktioniert perfekt.

Wie hast Du denn bzgl. Text improvisiert?


Gruß Mr. President
  • Zum Seitenanfang

Enrico1705

Experte

Beiträge: 260

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Kärnten

Betriebssystem: Windows 7

9

Samstag, 7. Januar 2017, 04:03

Hallo,

beim Text habe musste ich mehrmals mit Textumbrüche bzw Leerzeichen/ -zeilen probieren. Immer wieder die Seite in der Vorschau anzeigen lassen.
LG Enrico1705
  • Zum Seitenanfang

Mr. President

Experten-Team

Beiträge: 20

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Schleswig-Holstein

Betriebssystem: Windows 7
Linux

10

Montag, 9. Januar 2017, 05:50

Das wäre mir zu umständlich. Ich werde die Struktur verändern, also separate Text und Bildcontainer verwenden.
Allerdings ist Dir hoffentlich bekannt, das es seit langem das "responsive Design" gibt, und das kann Xpage leider nicht.
Responsive bedeutet übersetzt, das sich der Code, also die Seite automatisch dem Endgerät anpasst: Smart, Tablet, PC.
Daher werde ich Xpage nicht mehr einsetzen, denn Cutex wird keine 8 herausbringen und wenn, wird deren responsive
genauso schlimm sein wie der Textumlauf.

Ich kann Dir nur raten, nutze CMS (bloß kein Joomla oder WordPress....) oder such´Dir ein Tool (Net Objects, CoffeeCup, Zeta, Webacapella....), das responsive Design beherrscht.


Gruß Mr. President
  • Zum Seitenanfang