Sie sind nicht angemeldet.

Raimund

Fortgeschrittener

Beiträge: 44

Xpage-Version: Xpage Internet Studio 6 Professional

Wohnort: Niederrhein

Betriebssystem: Windows Vista

1

Sonntag, 16. August 2015, 16:36

Aktionen verschwinden beim kopieren

Ich krieg hier gerade wieder die Krise mit diesem Programm. Jetzt habe ich mir mühsam meine Navigation gebaut, mit allerhand Aktionen, um diverse Container ein und auszublenden. Das funktioniert auch alles. Aber sobald ich den Obercontainer, in dem sich die gesamte Navigation befindet, kopiere und auf einer anderen Unterseite wieder einfüge, verschwinden auf der neuen Seite sämtliche Aktionen. Es kann doch nicht sein, das ich jetzt auf sämtlichen Unterseiten immer wieder alle Aktionen neu setzen muss. Das dauert ja ewig. Ein Template kann ich auch nicht nehmen. Denn da funktioniert es mit den Aktionen auch nicht. Denn wenn ich da einem Container eine Aktion zuordne, wird diese Aktion automatisch für alle in dem Template befindlichen Container mit gesetzt. Was ist das denn für ein Unsinn? Ich muss echt sagen, das mich Xpage inzwischen gewaltig nervt. Ein produktives Arbeiten ist damit nicht möglich.
  • Zum Seitenanfang

derdj

Routiner

Beiträge: 78

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 6 Professional

Betriebssystem: Windows 8
Windows 7

2

Montag, 17. August 2015, 20:51

ist normal da neue objekte erstellt werden

Einfach die Seite mit Aktionen klonen,
passend benennen und Überschuss löschen, bzw fehlendes aus
erstellten Seite einfügen (ohne Aktionen).
  • Zum Seitenanfang

Ähnliche Themen