Sie sind nicht angemeldet.

Lauflust

Einsteiger

Beiträge: 8

Betriebssystem: Windows XP

1

Donnerstag, 21. Januar 2010, 15:33

Probleme mit Firefox und Internet Explorer

Hallo,
folgende Probleme habe ich mit meiner Homepage www.lauflust-re.de :
1. Firefox: Firefox zeigt die erstellte Homepage zwar richtig an nur leider stürzt Firefox regelmäßig ab, wenn ich auf die einzelnen Seiten der Homepage (Kontakt, Impressum usw.) klicke. Firefox, Java und Adobe Flash sind auf dem neuesten Stand.
2. Internet Explorer: Hier kommt es zu keinem Absturz, aber ein OLE Container (Welthungerhilfe) wird nicht richtig angezeigt und ein Bild auf der Kontaktseite wird gar nicht angezeigt.
Hat jemand eine Idee? Danke.
  • Zum Seitenanfang

Oliver Wendt

Experten-Team

Beiträge: 207

Xpage-Version: Xpage Internet Studio 6 Professional
Xpage Internet Studio 6 SE
Xpage Internet Studio Shop-Designer

Wohnort: Ulm

Betriebssystem: Windows 7
MAC OS X

2

Donnerstag, 21. Januar 2010, 15:39

Problem ist da, aber nicht nachvollziehbar wodurch es ausglöst wird.

Mein Tipp:
Bevor Sie irgendwelche Banners einbinden, versuchen Sie doch bitte die Seite erst einmal so zum Laufen zu bekommen (ohne Banner).
Dann können wir auch genauer feststellen welches die Ursache ist.

Gruss aus Ulm

Oliver Wendt
  • Zum Seitenanfang

Lauflust

Einsteiger

Beiträge: 8

Betriebssystem: Windows XP

3

Donnerstag, 21. Januar 2010, 16:03

Firefox und Internet Explorer

Nun habe ich sowohl die OLE Container als auch das Bild gelöscht und nun funktionieren beide Browser ohne Probleme! Das Problem ist damit eingegrenzt, leider aber noch nicht gelöst :-(
  • Zum Seitenanfang

Oliver Wendt

Experten-Team

Beiträge: 207

Xpage-Version: Xpage Internet Studio 6 Professional
Xpage Internet Studio 6 SE
Xpage Internet Studio Shop-Designer

Wohnort: Ulm

Betriebssystem: Windows 7
MAC OS X

4

Donnerstag, 21. Januar 2010, 16:17

Wie ich vorher gesehen habe waren es zwei Banner.
Jetzt mal einen nachdem anderen austesten.
Dann nochmals melden.

Oliver
  • Zum Seitenanfang

Lauflust

Einsteiger

Beiträge: 8

Betriebssystem: Windows XP

5

Donnerstag, 21. Januar 2010, 16:34

Das Problem entsteht schon mit dem ersten OLE Container. Internet Explorer hat keine Probleme, aber Firefox! Es kommt wieder zum Absturz. Der Inhalt des Ole-Containers (Url) lautet: http://dech.mbt.com/retailers/bannerCamp….swf?lang=de-DE.
  • Zum Seitenanfang

Oliver Wendt

Experten-Team

Beiträge: 207

Xpage-Version: Xpage Internet Studio 6 Professional
Xpage Internet Studio 6 SE
Xpage Internet Studio Shop-Designer

Wohnort: Ulm

Betriebssystem: Windows 7
MAC OS X

6

Donnerstag, 21. Januar 2010, 16:42

Haben Sie nur den Link für den obengenannten Banner eingesetzt?
Wenn ja nehmen Sie bitte einmal alles nach .swf weg.
Läuft der zweite Banner?
  • Zum Seitenanfang

Lauflust

Einsteiger

Beiträge: 8

Betriebssystem: Windows XP

7

Donnerstag, 21. Januar 2010, 16:58

Hallo Herr Wendt,
der zweite Banner läuft auch bei Firefox ohne Probleme. Allerdings wird weder bei Firefox noch beim Internet Explorer der Banner in der richtigen Größe angezeigt, obwohl ich die Größe im OLE Container richtig angegeben habe. Die Idee alles nach swf wegzulassen funktioniert beim ersten Container leider nicht!
  • Zum Seitenanfang

Oliver Wendt

Experten-Team

Beiträge: 207

Xpage-Version: Xpage Internet Studio 6 Professional
Xpage Internet Studio 6 SE
Xpage Internet Studio Shop-Designer

Wohnort: Ulm

Betriebssystem: Windows 7
MAC OS X

8

Freitag, 22. Januar 2010, 10:46

Hallo Lauflust.

Die Problematik liegt hier an der richtigen Einbettung der swf-datei.
Sie können es gerne ein mal mit meinem Tutorial Tutorial Flash und Lightbox in Xpage einbinden versuchen. Sie können hier auch externe swf files einbinden.
Wichtig ist, das die "swfobject.js" richtig eingebunden wird.

Gruss aus Ulm

Oliver Wendt
  • Zum Seitenanfang

Lauflust

Einsteiger

Beiträge: 8

Betriebssystem: Windows XP

9

Freitag, 22. Januar 2010, 15:24

Hallo Herr Wendt,
kann ich das Tutorial auch mit meiner Xpage Version 5.4.2 durchführen. Ich komme nur bis: Kopieren Sie aus dem oberen Teil die script Definitionen. Wo soll denn anschließend eingefügt werden?
  • Zum Seitenanfang

Oliver Wendt

Experten-Team

Beiträge: 207

Xpage-Version: Xpage Internet Studio 6 Professional
Xpage Internet Studio 6 SE
Xpage Internet Studio Shop-Designer

Wohnort: Ulm

Betriebssystem: Windows 7
MAC OS X

10

Freitag, 22. Januar 2010, 16:34

Hallo Lauflust!

Sorry mein Fehler,
Habe erst jetzt erkannt, dass Sie mit der 5er Version arbeiten.
Ich bin mir zwar nicht ganz sicher, aber ich glaube mit dieser Version haben wir schlechte Karten. (Vielleicht kann einer meiner Kollegen hierzu was sagen)
Das wäre jetzt vielleicht ein guter Zeitpunkt sich über die Anschaffung der Pro Version 6 gedanken zu machen ;)

Gruss aus Ulm

Oliver Wendt
  • Zum Seitenanfang

Lauflust

Einsteiger

Beiträge: 8

Betriebssystem: Windows XP

11

Freitag, 22. Januar 2010, 16:40

Hallo Herr Wendt,
die Gedanken mache ich mir gerne. Natürlich sollte die 6er Version auch mehr bieten als die 5er und vor allem funktionieren! Die Einbindung der OLE Container scheint mir problematisch zu sein.
  • Zum Seitenanfang

Oliver Wendt

Experten-Team

Beiträge: 207

Xpage-Version: Xpage Internet Studio 6 Professional
Xpage Internet Studio 6 SE
Xpage Internet Studio Shop-Designer

Wohnort: Ulm

Betriebssystem: Windows 7
MAC OS X

12

Freitag, 22. Januar 2010, 16:54

Hallo Lauflust!

Ich möchte keine "Schleichwerbung" machen. Jedes Programm hat seine Pro & Kontra Seiten.
Aber gerade diese "Containertechnik" ist es die Xpage unteranderem so intressant macht.
Desweiteren sind die gestalterischen Möglichkeiten eine der stärken von Xpage. So ist z.B. das integrierte Buttontool eines der Besten die ich in einem wysiwyg Programm bis jetzt gefunden habe.
Ich gebe Ihnen recht das die "Geschichte mit dem OLE Container nicht einfach ist, aber durch diese Technik haben Sie eine Möglichkeit "über den Tellerrand" der internen Programmierung hinaus zuschauen.

Letztendlich ist es natürlich Ihre Entscheidung.


Grüsse aus Ulm

Oliver Wendt
  • Zum Seitenanfang

renalex

Einsteiger

Beiträge: 4

Xpage-Version: Xpage Internet Studio 6 Professional

Betriebssystem: Windows 7

13

Montag, 30. Juli 2012, 12:09

Ich hätte wahrscheinlich erstmal im Absturzbericht vom FF gesucht, und wahrscheinlich mit Chrome und Opera auch noch probiert :P
  • Zum Seitenanfang