Sie sind nicht angemeldet.

Oliver Lorch

Einsteiger

Beiträge: 11

Xpage-Version: Xpage Internet Studio 6 Professional

Betriebssystem: Windows 7

1

Dienstag, 23. November 2010, 08:11

Auto-Upload von projektfremden Dateien

Hallo zusammen,



ich haben aktuell zwei Projekte parallel gestaltet und diese auch über die Autouploadfunktion auf die Webserver geladen. Die Seiten funktionieren eigentlich soweit fehlerfrei, aber wenn ich mir per Filezilla den Datenbestand ansehe stelle ich fest, dass in beiden Webverzeichnissen die Dateien von beiden Projekten zu finden sind.

Also, ich kann mir das nur so erklären, dass wenn man mehr als ein Projekt in XPAGE, während des Uploads, geladen hat, dann auch alle Dateien in das gleiche Verzeichnis upgeloaded werden. Kann das sein oder liegt mein Problem woanders?



Gruß

Olivber LoOrch
  • Zum Seitenanfang

Wassermann

Experten-Team

Beiträge: 336

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 7 SE

Wohnort: Schweiz

Betriebssystem: MAC OS X

2

Dienstag, 23. November 2010, 08:44

Hallo Aliver Lorch,

Dieser "Fehler" ist schon lange bekannt und ist im Forum schon länger diskutiert worden, Ich denke da es seit dem letztdem Update nichts gebessert hat wird es vermuttlich erst in der 7er Version "Hoffentlich" korrigiert sein. Seit der Diskusion wird empfohlen Nur immer ein Projekt geöffnet zu lassen um solches zu Vermeiden.

Gruss Wassermann
  • Zum Seitenanfang

Wildi27

Fortgeschrittener

Beiträge: 22

Xpage-Version: Xpage Internet Studio 6 Professional

Betriebssystem: Windows XP

3

Sonntag, 7. August 2011, 17:54

Falsche Daten werden hochgeladen !

Also ich habe mich jetzt schon mehrfach geärgert. Mit reinem Schließen eines Projektes ist es nämlich leider nicht getan ! Denn obwohl ich ein Projekt geschlossen und dann erst ein anderes Projekt geöffnet habe, werden beim Autoupload Dateien vom bereits geschlossenen Projekt hochgeladen. Aber auch bei einzelnen Dateien passiert das, speziell die Index.html. So ist es schon öfters vorgekommen, das ich etwas an einer Unterseite geändert habe, mit Autoupload hochgeladen und diese nur mit Aktualisieren des Browsers geprüft habe. Dabei habe ich nicht bzw. erst später beim erneuten Aufruf der Startseite bemerkt, das die falsche Index.html von einem geschlossenen Projekt hochgeladen wurde.

Also ich bin inzwischen soweit, daß ich Xpage fast immer bei jedem Projekt neu starte, was natürlich z.T. sehr lästig ist.

Weiß schon jemand wann die Version 7 erscheint ? Hoffentlich ist dieser Fehler da behoben !!!
  • Zum Seitenanfang

Achim Fricke

Experten-Team

Beiträge: 1 096

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 6 Professional

Wohnort: in Schleswig-Holstein Nähe Hamburg

Betriebssystem: Windows 7

4

Sonntag, 7. August 2011, 18:32

Hi Wild27,

verwenden Sie die aktuelle Version von Xpage? Ich habe seit geraumer Zeit dieses Problem nicht mehr beobachtet.

Gruß
Achim Fricke
  • Zum Seitenanfang