Sie sind nicht angemeldet.

Fredolino

Einsteiger

Beiträge: 5

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Bern

Betriebssystem: Windows 7

1

Montag, 24. Januar 2011, 21:19

Navigation unterschiedlich plaziert

Ich bin neu im Forum und auch mit Xpage. Habe eine einfache Homepage erstellt und alles funktioniert. Nur ein Problem: Eine Seite ist grösser als alle anderen. Bei der Vorschau und im Browser verschiebt es die Navigation, die sich oben befindet, immer ganz nach oben. Wenn ich die Navigation durchklicke, sind alle Buttons an der gleiche Position, ausser die von der grösseren Seite. Habe die Navigation einmal mit Templates und einmal mit einzelnen Objekten erstellt. Die grössere Seite verschiebt es immer, so oder so, warum?
  • Zum Seitenanfang

Achim Fricke

Experten-Team

Beiträge: 1 096

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 6 Professional

Wohnort: in Schleswig-Holstein Nähe Hamburg

Betriebssystem: Windows 7

2

Montag, 24. Januar 2011, 21:35

Hi, Fredolino, willkommen !

Größer heißt breiter, oder länger, oder beides?
Muss diese Seite andere Ausmaße haben?
Haben Sie die Seiten zentriert?
Warum Navigation mal mit Template, mal ohne?

Am besten, Sie lassen die Seite mal anschauen; also bitte den Link angeben, unter dem sie aufgerufen werden kann.

Gruß
Achim Fricke
  • Zum Seitenanfang

Fredolino

Einsteiger

Beiträge: 5

Xpage-Version: Xpage Internet Studio 7 Professional

Wohnort: Bern

Betriebssystem: Windows 7

3

Montag, 24. Januar 2011, 21:52

Hallo Hr, Fricke. Besten
Dank für die schnelle Antwort. Die eine Seite ist einfach nur länger und alles andere ist gleich. Die Homepage ist noch nicht fertig und kann ich noch nicht ins Internet stellen, da schon eine andere Seite geladen ist. Einmal mit und einmal ohne Templates war nur zum testen, ob es daran liegen kann.
Gruss
  • Zum Seitenanfang

Achim Fricke

Experten-Team

Beiträge: 1 096

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 6 Professional

Wohnort: in Schleswig-Holstein Nähe Hamburg

Betriebssystem: Windows 7

4

Montag, 24. Januar 2011, 21:55

o.k.Fredolino,

dann können Sie mir gern die Projektdatei (????.XPG) einmal zum Anschauen mailen, wenn Sie mögen; so ist mir eine (Fern-) Diagnose nicht möglich.

Gruß
Achim Fricke
  • Zum Seitenanfang

Achim Fricke

Experten-Team

Beiträge: 1 096

Xpage-Version: Xpage Internet Studio 7 Professional
Xpage Internet Studio 6 Professional

Wohnort: in Schleswig-Holstein Nähe Hamburg

Betriebssystem: Windows 7

5

Dienstag, 25. Januar 2011, 09:23

Hi Fredolino,
Dass die Navi springt, ist völlig normal. Sie haben im Layout die Option Postion der Seite im Browserfenster Zentriert eingeschaltet. Bei einem großen Monitor passen alle Seiten zentriert auf den Schirm, die fragliche, mit 5000 px sehr lange Seite lässt sich aber nicht komplett zentriert darstellen; deshalb zeigt der Browser "in seiner Not" so viel wie möglich von ihr, und schubst alles nach oben.
Mögliche Abhilfe: Ihre Standardseitengröße wählen, Inhalt auf eine Scrollpane packen.
Gruß
Achim Fricke
  • Zum Seitenanfang